This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

20050208 hyperthreading bug is back ?

I reported before that the 20050206 snapshot appeared to fix
the hyperthreading bug for me.

Now it seems that the next snapshot 20050208 broke it again.

Test Case:
  find z | while read f; do chown username "$f"; done;

and a longer version of the test case command, (same results):
  export i=1; find z | while read f; do printf "%8i: %s\n" $i "$f"; \
  chown username "$f"; ((i++)); done;

Note: z is a directory tree under /cygdrive/c with 4000 odd files in it.

  after 700 to 1000 files bash hangs with the following error message:
  2 [exiting thread] bash 3328 cygthread::stub: erroneous thread
    activation, name is NULL

The first number varies (2, 4, 8) as well as the number after "bash"
which I take it is the pid.

NOTE: The error only occurs when I run this from the command prompt.
I put the same command in a file (preceded by a #!/bin/bash -line)
and called it chownz.bash
./chownz.bash completes as expected
. ./chownz.bash also completes as expected

The same test runs without problems on the 20050206 snapshot.

My system:
HP Pavilion, P4HT3.2G, 1G memory, 200G SCSI HD

$ uname -a
CYGWIN_NT-5.1 nodename 1.5.13s(0.118/4/2) 20050208 14:21:58 i686
  unknown unknown Cygwin

I tried to include the output from
  'cygcheck -s -v -r | tee cygcheck.out'
but the interface will not accept lines longer than 80 chars.
I can mail it across, just let me know.

Regards CV

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]