This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: sshd and /usr/bin/zsh

Krzysztof Duleba wrote:
Brad King wrote:
I just upgraded cygwin and now I cannot login to the machine via ssh
unless I change /etc/passwd to use /bin/bash for my shell.  If I use
/usr/bin/zsh then the login appears successful but no prompt ever shows

Right, but did you try to type any command? When I do ssh localhost zsh -l I don't get prompt as well, but commands work fine.

I get the same behaviour with and without -l, with zsh and bash, on
Cygwin, Linux and Solaris. I guess it's not Cygwin related problem at all.

Yes, I tried typing commands but nothing happens. The .z* files are not executed either (I tried adding commands to them that create files and the files don't show up). It also DOES work if I login as a user with admin priviledges. As I said, this was all working fine before I upgraded cygwin yesterday, so it must be some minor change that came in with the upgrade. Therefore I strongly suspect it is a cygwin problem.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]