This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Running cygwin service via cygrunsrv under account without password in Win XP Pro - impossible?

> cygrunsrv: Error starting a service: StartService:  Win32 error 1069:
> The service did not start due to a logon failure.
> This happens only if my account has no password. Once I set any password - 
> it works great. Autossh starts under cygrunsrv as a service under my account 
> and sets all my ssh tunnels and everything works perfect. I remove password, 
> then try every possible way to tell Windows to run it under account without 
> password - no luck. Error 1069 again and again.
> My account has administrative privileges and "logon as a service" privilege. 
> I use Windows XP Professional. The cygwin version is the latest (installed 
> two days ago).
> cygrunsrv.README says:
> -w, --passwd <password>
>   Optional password for user. Only needed if a user is given. If a
> user has an empty password, enter `-w ' with no <password>.
> cygrunsrv -I svc_name -p /usr/bin/svc.exe -u foo -w ""

Isn't '-w ""' different from just '-w'?  In other words,
cygrunsrv.README is telling you to use no password, while you're giving
it an empty password, which is different.  I dunno, but it's worth a

> This is what I have tried, plus I tried omitting -w option at all and just 
> pressing Enter key when asked for password by cygrunsrv interactively. I 
> also tried setting empty password in the Services control panel, by going to 
> the service properties and then setting my account and empty password in the 
> LogOn tab there. All with the same result - error 1069.
> Here's the cygrunsrv command lines I've tried (neither works):
> cygrunsrv -I ubcgw -p /bin/autossh -t manual -a '-M 0 -L 143:imap:143 -L 
> 25:smtp:25' -e AUTOSSH_NTSERVICE=yes -u vadym -w ""
> cygrunsrv -I ubcgw -p /bin/autossh -t manual -a '-M 0 -L 143:imap:143 -L 
> 25:smtp:25' -e AUTOSSH_NTSERVICE=yes -u vadym

So you could try the first one again, leaving the '-w' but omitting the

Another option is to run the service as user SYSTEM.  This is what I do,
and I've never had any trouble.  But of course you're right to try to
run it under a lower-privilege account.

Good luck, and let us know what you find out.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]