This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: zsh: command not found => hangs

On Thu, 25 Aug 2005, Samuel Thibault wrote:

Peter A. Castro, le Wed 24 Aug 2005 16:21:16 -0700, a écrit :
On Tue, 23 Aug 2005, Samuel Thibault wrote:

With latest snapshot, whenever I mistype a command in zsh, I get proper zsh: command not found: foobar but then it hangs. This doesn't happen with bash though.

Umm... some details about your config would be helpful :)

Ah, sorry. My config is not very particular so I thought it would be easy to reproduce. I tried to change PS1 to foo, it still fails.

Note that I replaced cygwin1.dll by the latest snapshot (2005/08/24).
The current release version (2005/07/03) does work fine. I tried with
previous snapshots, even 2005/07/05 fails...

Wait, so the released version works, but the snapshot doesn't?

Do you have any network drives in your $PATH?  I seem to recall someone
else had problems with a network drive being slow causing problems
(though I could never repro it myself).  This seems real familiar...

Hmmm... Well, I guess the only thing to do is run strace, make it fail
and send us the trace.

Are snapshots compiled differently than release versions? Is there
anything particular to do when installing them, except closing programs,
replacing the old one with the new one, and relaunch programs?

As Larry already responded (no and no), I'll just add that you should make sure you stop and restart any cygwin services too.


-- Peter A. Castro <> or <> "Cats are just autistic Dogs" -- Dr. Tony Attwood
Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]