This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 1.5.18: ld command generates stackdump

PS = Peter J. Stieber
PS>>> Sorry in advance for the stupid questions, but...
PS>>> I downloaded the binutils source package, and
PS>>> extracted the source. When
PS>>> I ran
PS>>> ./configure --help
PS>>> I didn't see a --enable-debug option or anything
PS>>> I though was equivalent. Am I missing something?

BD = Brian Dessent
BD>> Normally, auto-tooled packages like binutils have a
BD>> default value for CFLAGS that is typically "-g -O2"
BD>> which means you get the debug information.  When
BD>> creating binary packages for distribution the
BD>> binaries are typically stripped later.

PS> Thanks for the info Brian. I ran ./configure successfully
PS> in the extracted binutils-20050610-1 directory. When
PS> I ran make I ran into the following error:

A bunch removed.

PS> I'm not quite sure what the problem is. I have bison,
PS> flex and byacc loaded.

Actually I loaded them after the error. After I removed the build
directory and started over the code is building fine now. I will send
the backtrace for my particular ld problem when I am through. BTW I have
successfully built other codes with the same ld. I'm just getting a ld
crash with one particular code. I guess that's obvious considering I'm
building binutils with the same ld command.

Thanks to all of the cygwin developers for their efforts,

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]