This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: services not starting with 20060104 snapshot

On Wed, 4 Jan 2006, Brett Serkez wrote:

> > Frankly, I'm not sure what the right fix would be in this case, or
> > even how to debug this...  Any ideas on how I can simulate service
> > startup on the command line (to allow popping up gdb) would be greatly
> > appreciated.
> Try using a graphical debugger like ddd or insight.  Should be able to
> start either as the service,

Huh?  No, that doesn't work.  I need a service wrapper program (like
cygrunsrv), but cygrunsrv can't spawn processes, apparently.

> which start the actual service under debug control and open the X
> display for interaction, allowing debug of the service.  From the issue
> your trying to debug, not sure if the debugger itself would effect the
> behavior.

The other problem is that the debugger does not call service_main, as the
SCM does, so the behavior *is* different.
      |\      _,,,---,,_ |
ZZZzz /,`.-'`'    -.  ;-;;,_		Igor Peshansky, Ph.D. (name changed!)
     |,4-  ) )-,_. ,\ (  `'-'		old name: Igor Pechtchanski
    '---''(_/--'  `-'\_) fL	a.k.a JaguaR-R-R-r-r-r-.-.-.  Meow!

"Las! je suis sot... -Mais non, tu ne l'es pas, puisque tu t'en rends compte."
"But no -- you are no fool; you call yourself a fool, there's proof enough in
that!" -- Rostand, "Cyrano de Bergerac"

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]