This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Querying the LIB environment (from g++) don't work with current cygwin.dll (1.5.19-4)

Hi all,

i can't query the LIB environment variable from C++ code, compiled with g++, with GetEnvironmentVariable, as demonstrated in the appended, small example program. Other variables (e.g. PATH could be retrieved without problems). The example program queries LIB and prints it out. The output i received is an empty string.

I've installed the current cygwin version.

If i go back with the cygwin dll to 1.5.18-1 it worked without problems!!! But than a lot of other cygwin tools don't worked.

The problem occured originally on compiling the Coin3D library. They are using a cygwin compiled wrapper program (wrapmsvc.exe), which is querying the LIB variable and failed.

Many thanks for any hints

#include <iostream>

#include <Windows.h>

int main( void )
  const int bSize = 32657;
  char buffer[bSize];
  int resultsize = GetEnvironmentVariable("PATH", buffer, bSize);
  std::cout << "PATH: " << buffer << std::endl;
  buffer[0] = 0;
  resultsize = GetEnvironmentVariable("LIB", buffer, bSize);
  std::cout << "LIB: " << buffer << std::endl;

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]