This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: chroot bug?

On Mar  2 04:56, Eric Blake wrote:
> I noticed the following strange behavior in chroot:
> $ chroot /bin /sleep 60 &
> [1] 16220539
> $ readlink /proc/${!}/root  # simple test of whether chroot worked
> /bin
> $ chroot //EBLAKE/share /cygwin/bin/sleep 60 &
> [2] 566487
> $ readlink /proc/${!}/root   # Good - chrooted to a share
> //EBLAKE/share
> $ chroot // //EBLAKE/share/cygwin/bin/sleep 60 &
> [3] 529435
> $ readlink /proc/${!}/root        # Oops - should be //, not /
> /
> $ chroot //EBLAKE/share/cygwin/bin/sleep 60 &  # Oops, failed to chroot
> [4] 566487
> $ chroot: cannot chdir to root directory: No such file or directory
> Why is chroot failing to find //EBLAKE, when it worked with // (at
> least, it slept correctly, although root linked to the wrong place),
> and did just fine with //EBLAKE/share?

I debugged this and I found the problem.  However, there's no easy
workaround.  The basic problem is that you try to chmod to a path
which either doesn't exist, or is not a valid Win32 path, for
instance //server/share is a valid path, but //server or // are not.
Same goes for paths like /proc or the cygdrive directory.  The best
solution, at least for now, is to refuse to chroot to such a path.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]