This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: random "fork: Resource temporarily unavailable"

Hash: SHA1

- -----Original Message-----
> From: []On Behalf
> Of Linda Walsh
> Sent: Thursday, June 15, 2006 6:06 PM
> To:
> Subject: random "fork: Resource temporarily unavailable"
> I've not seen this message except when I've had to rapidly
> press ^C to break out of a loop shell script.
> Today, I've seen it twice when there was virtually no cpu load
> on the system, about 50% virtual memory committed, and 40 processes.
> Once, was with an "ls" command, the other happened as my shell was
> starting up by some command invoked in the .rc script.
> I get suspicious whenever I see behavior on my computers when
> anomalies crop up.
> I don't think any of my cygwin libraries have been updated recently.
> What would cause something like this?  Memory fragmentation?
> Insufficient real memory to "immediately" fork?  I.e. I wonder
> if, when NT goes to "fork", if it doesn't have enough free
> memory, it tells the caller it failed (try again later) and
> then starts a memory cleanup cycle to free up memory: i.e. rather
> than the forking process sleeping while memory is made available
> NT returns it immediately with a failure.
> Any idea on causes?  Is it as rare as it has been for me?
> A possible solution would be retry the fork a second time, or
> sleep for a millisecond and then try fork again. I'm not sure,
> but I think many *ixy (*='un'|'pos'|'lin'|'ir'...etc) type programs
> may not retry the fork  but immediately die, as on *ixy systems,
> a fork failure is less common, and usually only happens when
> the system really is out of resources.  If that's the case,
> it _might_ be an aid to smooth *ixy compatibility for the
> library handling fork, retry the fork (possibly with millisecond
> sleep) once before returning failure to the application.
> Not a high priority issue, but just wondering....
> Linda
> If it is NT returning failure rather than
> forking, I wonder if, in order to provide a better "run-time"

Confirmed.  This happens on Windows 2000 Service Pack 4, with the latest *stable* cygwin1.dll.  It happens when I even run a configure script, or anything else.  It's rare, you're right Linda, and it happens at any time (also a bit annoying).  The temporary workaround for me is to just restart the whatever and get on with life.

Version: GnuPG v1.4.3 (Cygwin)


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]