This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: bash and CSRSS consuming 100% of CPU

Thanks for the suggestion, Brian.  Unfortunately, it did not help the
problem at all.

I am not 100% sure what you meant by "try a snapshot," but I am guessing
that you meant simply to reinstall cygwin.  So I did that, again.  Last
night I renamed the old cygwin directory from C:\cygwin to C:\cygwin_OLD,
then I downloaded from the cygwin web site an all-new installation into
C:\cygwin.  I brought up a bash window under this new installation, and
within a few minutes the CPU utilization jumped up to 100% just like before,
making my PC virtually unusable.  The utilization drops back to normal when
I kill the bash window.

I ran cygcheck again and have attached the output file.

Somebody reported this same problem two years ago:

He was told to try reinstalling cygwin.  He did that, and reported (like me)
that reinstallation did not help.  Nobody offered him any further
suggestions.  The fellow who posted the item two years ago provided a link
going all the way back to the year 2000, suggesting that this problem has
been around for a long time.

I will be happy to provide additional information if that will help in
tracking down the source of this problem.  It is quite disconcerting when an
excellent system such a cygwin, which worked beautifully on my PC for
several years, suddenly malfunctions like this and becomes useless.

Attachment: cygcheck.out
Description: Binary data

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]