This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: bash and CSRSS consuming 100% of CPU

On 20 June 2006 02:11, Science Guy wrote:

> I got cygwin working once again on my problem machine.  (Hooray!)
> The problem was that the snapshot tar file, cygwin-inst-20060614.tar.bz2,
> had cygwin1.dll in /usr/bin but failed to replace the old cygwin1.dll in
> /bin.  I copied over the new cygwin1.dll into /bin, and things are working
> nicely once again.

  Yes, tar can't replace the cygwin dll, because tar relies on having the
cygwin dll loaded in order to run!  You have to extract it separately and use
a dos prompt to copy it across.  You obviously read the FAQ entry, because you
knew to use the "--exclude=usr/bin/cygwin1.dll" option; read the bit just
after that again.  I guess it's only implied rather than explicit, that you
could have installed the dll first and the rest later; maybe we could make it

> My antivirus and antispyware software programs are still running on the same
> PC.  I did not touch them.  It will be a sad day when cygwin can no longer
> run alongside these programs.  Our corporate guidelines require us to have
> antivirus and antispyware software running on our corporate PCs; otherwise,
> we are denied connectivity to the corporate network.
> And anyway, shouldn't everyone run antivirus and antispyware programs on
> their PCs, corporate or private?  I love cygwin and think it's a great
> package, but disabling antivirus and/or antispyware software to enable
> cygwin to run seems like too high a price to pay.  Am I missing something
> here?

  Yes: we were only suggesting *temporarily* disabling them to identify if
they were the source of the problem.  A lot of anti-virus programs are
actually buggy and modify the operation of the system by inserting hooks left
right and center; if, as a result of that, something stops working, because
the hooks inserted by the AV aren't actually transparent to the application
that is being hooked, then it's the AV program's fault, not cygwin's.  It
should be reported as a bug to the AV software manufacturer.

Can't think of a witty .sigline today....

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]