This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: rsync changed ACL behaviour?

Mattias wrote:
Using rsync to update my web site on a Windows 2003 Server using the
following command

rsync --archive --stats /cygdrive/c/data/publish/ -e ssh

Worked fine for a year.


Stopped working recently. rsync doesn't set the ACL correctly. rsync
sets the rights of the Users user to nothing at all, which makes the
web site not work at all. (I have switched my laptop since it last
worked and reinstalled cygwin.)

So what changed?

After running rsync, I have to go to the server, opening the security
dialog for the directory, pressing advanced, selecting

"Replace permission entries on all child objects with enties shown
here that apply child objects"

These are the default permissions, so why doesn't rsync use them.
Which permissions do rsync use?

Depends on your configuration.  See the User's Guide
<> for more details on
permissions.  If you have a follow-up question, please read and
follow the problem reporting guidelines found here:


-- Mattias

P.s. Is there a simple way in cygwin setup.exe to just revert to an
older version of a single package, in my case rsync 2.6.3?

The trivial case is to rerun "setup.exe" and just install the previous
version.  If there are dependencies, this could be a more complex problem.
You may need to downgrade practically everything to make this work out. :-(
But I'd start with the easy option and proceed from there. ;-)

-- Larry Hall RFK Partners, Inc. (508) 893-9779 - RFK Office 216 Dalton Rd. (508) 893-9889 - FAX Holliston, MA 01746

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]