This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: CR/LF problems after upgrade

-----Original Message-----
From: Eric Blake [] 
Sent: Monday, January 08, 2007 11:27 PM
To:; Eramo, Mark
Subject: Re: CR/LF problems after upgrade

Hash: SHA1 - reformatted

> -----Original Message-----
> From: cygwin-owner AT cygwin DOT com
                    ^^^^      ^^^^^ - raw email munged

> On 1/5/07, fschmidt  wrote:
>> Okay, how can I set SHELLOPTS before invoking bash?  I tried it in
>> /etc/profile but that didn't work.

According to Eramo, Mark on 1/8/2007 9:33 AM:
> I have the same problem and I set this under the Windows System
> Variables as well as in the Cygwin shell window but neither worked. 

> Actually, it sounds like you don't have the same problem.

> I use tsch as opposed to bash. Is there something different that needs
> to be set in this shell? 

>tcsh is not the same as bash, and SHELLOPTS does not affect tcsh
>even with tcsh, you probably end up invoking a lot of sh scripts that
>affected).  You'll have to show a simple test case that someone else
>reproduce before we can offer help.

Don't work too hard, make some time for fun as well!

Eric Blake   

Thanks for the reply Eric. I actually tried this using bash first but I
think I maybe see what is wrong. 

First, I added the following Environment Variable


I then Opened Cygwin (envoking bash) and issued the SET command to see
the environment. As you can see below, the SHELLOPTS variable does not
have igncr included 


So, I just need to figure out why it's not picking it up (this must be
read only variable) and then how to get it added. Once I do that, I can
hopefully run an appropriate test. 



Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]