This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: gcc: installation problem, cannot exec 'cc1'

Thomas Antony wrote:
   This is my first post here. I recently installed Cygwin again
after my harddisk crashed and had to be formatted and all. I mainly
use an ELF cross compiler for doing OS dev. So it was when I tried to
compile a simple app using the normal GCC that I ran into this error.

$ gcc -mno-cygwin -o hello hello.c
gcc: installation problem, cannot exec 'cc1': No such file or directory

I see that it occurs only when I use the -mno-cygwin option. I
searched google. I found I have to install gcc-mingw package. I
installed it. But the problem still prevails. I also see that there is
no /usr/lib/gcc-lib directory. I found  cc1.exe in the
/lib/gcc/i686-pc-cygwin/3.4.4 directory. I tried adding that to the
PATH. But then I get the error.

ld: crt2.o: No such file: No such file or directory

Don't do that.

I have also tried reinstalling those packages (gcc, binutils etc.) .
But it still doesnt work.

I am also attaching the output of cygcheck -r -s -v , in case it helps.

What does 'ls -l /lib/gcc/'? You should have '/lib/gcc/i686-pc-mingw32/3.4.4' with cc1.exe in it (which is just a symbolic link to the one in the i686-pc-cygwin). If you don't have that, check /var/log/setup.log* for indications of installation glitches.

Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
216 Dalton Rd.                          (508) 893-9889 - FAX
Holliston, MA 01746


A: Yes.
> Q: Are you sure?
>> A: Because it reverses the logical flow of conversation.
>>> Q: Why is top posting annoying in email?

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]