This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Can't start cron daemon in Cygwin 1.5.23 under WinXP SP2

--- Steve Rowley <> ha scritto:

> >Date: Mon, 22 Jan 2007 15:16:19 -0800
> >From: Brian Dessent <brian at dessent dot net>
> >
> >Steve Rowley wrote:
> >>     >In case of problem, examine the log file for
> cron,
> >>     >/var/log/cron.log, and the Windows event log
> >>     >for information about the problem cron is
> having.
> >
> >This is the key thing to look at, the actual reason
> for why it can't
> >start should be in one of those two locations.
> Excellent points.  Here are the results:
> (1) There is no /var/log/cron.log.  Since this is
> the first time I've
>     tried to bring up cron on this machine, I take
> it to indicate that
>     the daemon never got as far as creating its log
> file.
> (2) Windows event log: yes, there are some
> cron-related events there.
>     Had I read the message as carefully as you did,
> I would have
>     found Application events like this:
>     >Event Type:	Error
>     >Event Source:	cron
>     >Event Category:	None
>     >Event ID:	0
>     >Date:		1/22/2007
>     >Time:		11:00:27 PM
>     >Computer:	CBDWB00033
>     >Description:
>     >The description for Event ID ( 0 ) in Source (
> cron ) cannot be found. The local computer may not
> have the necessary registry information or message
> DLL files to display messages from a remote
> computer. You may be able to use the /AUXSOURCE=
> flag to retrieve this description; see Help and
> Support for details. The following information is
> part of the event: cron: PID 304: starting service
> `cron' failed: fork: 11, Resource temporarily
> unavailable.
> Any idea what to make of that?
> >>     >/usr/bin/cygrunsrv: Error enumerating
> services: OpenService:  Win32 error 5:
> >>     >Access is denied.
> >
> >This usually just means there's a registry key for
> a service that has an
> >ACL that returns an error when cygrunsrv tries to
> query its information
> >to find out if it's a Cygwin service.  Most of the
> time this can be
> >ignored [...]
> Good, then we'll all happily ignore it.
> >> [ATTACHMENT ~/My Documents/cygcheck_output.txt,
> text/plain]
> >
> >You didn't actually attach anything, just this
> text.
> Silly me.  I actually understand why that happened,
> but won't bore you
> with the reason, unless I can think of an
> entertaining way to tell it.
> In any case, I've reattached the output of cygchek
> to this message.

possible issue:
the user SYSTEM has no enough permission to execute
or to write in certain directories.
   ls -l
to check permissions of the involved file/directories.

For me, some changes of permission 
from 700 to 755 or 750
solved a similar problem with OpenSSH and NFS .

SYSTEM belongs to the administrators group
but it is not admin/root
$ grep SYSTEM /etc/passwd

$ grep 544 /etc/group



Vinci i biglietti per FIFA World Cup in Germania!

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]