This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

sshd - inconsistent app behavior vs console

I am trying to setup remote backups using vshadow.exe to create a drive
snapshot (Volume Shadow Copy Service). When I run vshadow from a console
bash prompt it works fine, but if I ssh to the host and run it remotely
it does not.

It appears that there is something different between the bash
environment I get via sshd and the one I get by opening the bash prompt
via the start menu. I have verified that the bash.exe process that runs
when I ssh is owned by my user account and other than some differences
in environment variables, I can't see any difference between the bash
processes. Everything else I've tried via ssh has worked ok.

I believe that vshadow does interact with other services on the host. I
did come across some prior messages in the list archive that suggested
there was a problem with this via sshd. I was not able to find any clear

Any ideas??

I'm running the latest cygwin code on Windows XP sp2. I don't think
there is anything special or unusual about my setup.

Here's what I get when I run vshadow from an ssh session. I get the same
error on two different hosts.

$ ./vshadow.exe c:

VSHADOW.EXE 2.2 - Volume Shadow Copy sample client
Copyright (C) 2005 Microsoft Corporation. All rights reserved.

(Option: Create shadow copy set)
(Gathering writer metadata...)
(Waiting for the asynchronous operation to finish...)
Error during the last asynchronous operation.
- Returned HRESULT = 0x80042318
- Please re-run VSHADOW.EXE with the /tracing option to get more details


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]