This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: ssh ProxyCommand not finding anything to execute

Thanks for your reply Jason.
I have also tried putting it in a config file but it had the same result.  I
ended up using the command-line just because I could be sure that it was
using correct parameter.

I did look at corkscrew, however I couldn't find a precompiled download.  I
know I can compile it but I dont have a full cygwin install, and I am trying
to make it as simple for other people to follow.

I know I must be doing something really simply wrong, but I just can't think
what it is!

Thanks again.


DePriest, Jason R. wrote:
> On 9/17/07, SQueeZe <> wrote:
>> Hi All
>> I am trying to connect to my home computer from work and I have to use
>> the
>> work HTTP proxy on port 443 in order to do so.  I have done this using
>> PuTTY
>> just fine so I know there is nothing wrong with my setup.  I have
>> downloaded
>> the windows binary of Connect and placed it in the same folder as the ssh
>> binary (c:\cwrsync\bin).  If I try to run the connect command by itself
>> in
>> debug mode I can connect to the proxy and thus my home PC just fine:
>> bash-3.00$ connect -d -H proxy:8085 myhomepc 443
> - - -  deleted DEBUG - - -
>> SSH-2.0-OpenSSH_4.3p2 Debian-9
>> DEBUG: sent 2 bytes
>> DEBUG: recv 19 bytes
>> Protocol mismatch.
>> DEBUG: connection closed by peer
>> DEBUG: relaying done.
>> DEBUG: that's all, bye.
>> I have installed cwRsync which has the OpenSSH client version 4.5.  I
>> should
>> be able to type in the following:
>> ssh -v -o ProxyCommand="connect -H -d proxy:8085 %h 443" user@myhomepc
>> However I get the following error:
>> OpenSSH_4.5p1, OpenSSL 0.9.8d 28 Sep 2006
>> debug1: Executing proxy command: exec connect.exe -H proxy:8085 myhomepc
>> 443
>> debug1: permanently_drop_suid: 400
>> /bin/sh: No such file or directory
>> debug1: identity file /cygdrive/c/Documents and
>> Settings/myuser/.ssh/identity type -1
>> debug1: identity file /cygdrive/c/Documents and
>> Settings/myuser/.ssh/id_rsa
>> type 1
>> debug1: identity file /cygdrive/c/Documents and
>> Settings/myuser/.ssh/id_dsa
>> type -1
>> ssh_exchange_identification: Connection closed by remote host
>> The problem is that it doesn't seem to be finding the connect binary.  If
>> I
>> remove all the "connect.exe...." stuff and just leave it as "" or put
>> random
>> stuff in there, I get exactly the same error.  C:\cwRsync\bin is in my
>> variable so I can type it from anywhere.
>> I have tried specifying the location with:
>> C:\cwRsync\bin\connect
>> /cygdrive/c/cwRsync/bin/connect
>> and I have tried copying the binary to various places on my hard drive to
>> no
>> avail.
>> My understanding is that I should get some output from Connect once it
>> finds
>> it as I have specified the -d flag.
>> What am I doing wrong?
>> Thanks
>> SQueeZe
>> --
> Hello.
> I have used the ProxyConnect option successfully.  However, I do not
> use your method.
> Instead, I modify my ~/.ssh/config file to contain ProxyCommand
> sections for specific IP addresses or hosts.
> It might make your command line a little bit easier to read and would
> elimiate potential quoting errors.
> I am also using corkscrew instead of connect.exe for ProxyCommand and
> I compiled it myself inside of cygwin.
> See man ssh_config
> Also
>> Problem reports:
> -Jason
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

View this message in context:
Sent from the Cygwin Users mailing list archive at

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]