This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Tail not reading to end of input

On Apr 16 14:49, Corinna Vinschen wrote:
> On Apr 16 06:23, Eric Blake wrote:
> > According to smr xxxx on 4/14/2008 11:56 AM:
> > | Hi, I've just rebuilt my machine and done a clean install of the
> > | latest Cygwin, and am having a problem with tail.  I'm wanting to know
> > | whether this is a known issue before digging deeper.
> >
> > Not known to me, but I (thankfully) don't use Vista.
> I can reproduce this problem on Windows 2008.  Pipes created by cmd on
> Vista/2008 are for some reason not recognized as pipes when using Cygwin
> 1.5.25-11.  This problem does not occur with the upcoming Cygwin 1.7.0
> so it's fixed in CVS, apparently.

The reason is that starting with Windows Vista/2008, anonymous pipes
don't have a filename attached to them, so that the call to
NtQueryObject in handle_to_fn fails with STATUS_OBJECT_PATH_INVALID.
This is handled gracefully for pipes in CVS, but not yet in 1.5.25-11.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]