This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: flex: exec failed? (root install/mount)

configure:10596: /obj/gcc.5/i686-pc-cygwin/i686-pc-cygwin/build-i686-pc-cygwin/flex/flex conftest.l
strace: error creating process D:\\obj/gcc.5/i686-pc-cygwin/i686-pc-cygwin/build-i686-pc-cygwin/flex/flex, (error 3)

which indicates the problem is:

$ mount
d:\bin on /usr/bin type system (binmode)
d:\lib on /usr/lib type system (binmode)
d: on / type system (binmode)
c: on /cygdrive/c type system (binmode,noumount)

d: is being interpeted, as it is on Win32, as the current directory on drive d, and not, as intended here, as the root of d.
I tried unmounting it and explicitly mounting d:\, d:\\, d:/, but they still all got treated as d:.
Tried editing the registry, same thing. Used d:\foo also to make sure what I was doing was being seen by the code.

Another way to achieve what I want is for d:\cygwin to be an NTFS junction do d:\, but then I have circularities in my file system, which I'd rather avoid.

I know installing to the root is discouraged, but..agreed this is a bug? Should be fixed? It is easy to fix? I think so, on all counts.
I'm sure I can provide a patch.

The /cygdrive mounts must deal with this specially??

 - Jay

> From:
> To:
> Subject: FW: flex: exec failed?
> Date: Wed, 16 Jul 2008 18:55:06 +0000
>> From:
>> To:
>> Subject: flex: exec failed?
>> Date: Wed, 16 Jul 2008 18:53:23 +0000
>> anyone familiar with this:
>> flex: fatal internal error, exec failed
>> flex: error writing output file lex.yy.c

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]