This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Control-c of a bat file does not kill commands run by bat file in some cases

Is this a bug or a feature?

When I run a program loop.exe   whose entire source is "int main() {   while(1);  return 0;}", compiled with MS VS8 or cygwin's gcc, from a bat file whose contents are just "loop.exe" and hit control-c while it is running, sometimes cygwin kills the loop.exe and sometimes it does not. Here are the 6 scenarios that I tried:

1. OKAY tcsh  from a cmd.exe 
2. OKAY bash from a cmd.exe 
3. BROKEN tcsh from an rxvt X window  on local machine
4. BROKEN bash from an rxvt X window on local machine
5. BROKEN tcsh via ssh from a remote machine  (public key auth)
6. BROKEN bash via ssh from a remote machine (public key auth)

OKAY means it kills the bat file and loop.exe
BROKEN means loop.exe continues to run after control-c.

bash/tcsh doesn't not seem to matter, I just did it because I first noticed the problem on tcsh.

At the very least, if it is a feature, it is inconsistent.

My cygwin installation is relatively up to date. This has been a problem for a long time and I'm just getting around to characterizing it. If you want a cygcheck output, or other information please let me know. My cygwin is 1.5.25-15.  If you want a C program instead of a bat file, I think we can do that.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]