This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Lost background and foreground color settings when upgrading rxvt to v2.7.10

> I've been happily using rxvt for a while using, what I understood to be, the out-of-the-box background and foreground color settings (dark blue and yellow respectively).
> After I installed a recent update using cygwin setup (obtaining rxvt v2.7.10) I get a white background and a black foreground (text).
> How can I get the original colors back ?
> I've tried the rxvt -background and -foreground options but can't seem to reproduce the original colors.
> Incidentally, on the upgrade, the value of the COLORFGBG environment variable changed from "default;default" to "0;default;15"

The rxvt package for cygwin itself hasn't been changed since 2007 Aug
27, so I doubt anything related to rxvt itself changed.

However, I ran into a similar problem with rxvt -- but it was due to the
recent X11 updates. Now, granted, rxvt has a native mode in which it
doesn't depend on X11. However, there is the following bug:

rxvt looks for its resource file in /usr/lib/X11/app-defaults/Rxvt (also
~/.Xdefaults, etc). It does not use X11 to do this; instead it locates
and parses the files manually. However, the cygwin rxvt package installs
the Rxvt resource file into /etc/X11/app-defaults/.

The old X11 packages created/maintained a symbolic link

/usr/lib/X11/app-resources -> /etc/X11/app-resources

The new ones do not, and that symbolic link is gone; I'm not sure if
that is a bug in the new X11 packages, or a deliberate change.   I will
eventually rebuild (the cygwin "native") rxvt to look in the correct
/etc/ location, but until then, manually create the symlink:

$ cd /usr/lib/X11
$ ln -fs /etc/X11/app-resources .

And you should be fine.  Also, I've noticed a similar issue with
rxvt-unicode-X: unfortunately the symlink trick doesn't work for it. I
had to set XAPPLRESDIR=/etc/X11/app-defaults in my system environment
for rxvt-unicode-X to be happy.


P.S. -bg and -fg WJFFM (/not/ -background or -foreground)

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]