This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: nearly all postinstall scripts segfaulting in 64bit Windows (XP + Vista)

On Fri, Nov 21, 2008 at 04:51:03PM -0500, Larry Hall (Cygwin) wrote:
> Lonni J Friedman wrote:
>> On Thu, Nov 20, 2008 at 3:40 PM, Lonni J Friedman wrote:
>>> Greetings,
>>> I'm attempting to setup a build environment, which happens to require
>>> cygwin.  I ran into no problems getting this up with 32bit Windows XP,
>>> however for both WINXP64 and VISTA64, the cygwin installation blows up
>>> badly while running all of the postinstall scripts (in
>>> /etc/postinstall).  Nearly all of them are segfaulting.
>>> For example, if I attempt to run /etc/postinstall/ manually, it
>>> churns for a few seconds, and then dies with the following output:
>>> 11 [main] bash 1644 +_cygtls::handle_exceptions: Error while dumping
>>> state ( probably a corrupted stack)
>>> Segmentation fault (core dumped)
>>> The only potential oddity in this equation is that my Windows (both 32
>>> & 64bit) installations are inside of Xen (running on a Linux system).
>>> I'm at a complete loss on how to debug this at this point.  Any and
>>> all suggestions are gratefully accepted.
>> No suggestions?  Anyway, it also looks like I'm getting a stackdump
>> every dump this segfaults which includs the following:
>> ######
>> Exception: STATUS_ACCESS_VIOLATION at eip=7D61C95D
>> eax=00000000 ebx=0022C4D8 ecx=00000000 edx=00000000 esi=FFFFFFFE 
>> ebp=0022C4A8 esp=0022C45C program=C:\cygwin\bin\bash.exe, pid 924, thread 
>> main
>> cs=0023 ds=002B es=002B fs=0053 gs=002B ss=002B
>> Stack trace:
>> Frame     Function  Args
>> 0022C4A8  7D61C95D  (00000274, FFFFFFFE, 0022C4D8, 00000001)
>> 61169E30  6101CDEB  (0000000F, 80100000, 00000274, 00000000)
>> 6113F9B8  0000044F  (610FE560, 610FE530, 610FDB40, 6101E4A0)
>> 610FE950  610FDB70  (90909090, 90909090, 90C3C031, 90909090)
>>      11 [main] bash 924 _cygtls::handle_exceptions: Error while
>> dumping state (probably corrupted stack)
>> ######
> There's been one other report, that I recall, of problems running
> Cygwin under Xen but AFAIK, no one on the list who's digging into
> the code is using it (or at least seeing the problem when using it.)
> Whatever the problem is, it seems specific to Xen since other VMs run
> Cygwin fine.  Certainly the stack suggests that the crash happens in
> bash and not the Cygwin DLL, though I'm not sure that this says much.
> ;-)

Actually the stack suggests that it is happening in a system call
(0x7D61C95D) from the cygwin DLL (0xc101CDEB) but your observations and
conclusions are still the same.  I'm not aware of anyone actively
investigating Xen problems.

Hopefully this observation won't trigger a "Well, it seems to me..." or
a "Death of Cygwin unless..." from anyone.


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]