This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

ssh-host-config problem on windows 2003, please help.

I am trying to automate my cygwin install on a windows 2003 box and have even done the following before ssh-host-config is run:

ntrights +r SeAssignPrimaryTokenPrivilege -u sshd
ntrights +r SeCreateTokenPrivilege -u sshd
ntrights +r SeDenyInteractiveLogonRight -u sshd
ntrights +r SeDenyNetworkLogonRight -u sshd
ntrights +r SeDenyRemoteInteractiveLogonRight -u sshd
ntrights +r SeIncreaseQuotaPrivilege -u sshd
ntrights +r SeServiceLogonRight -u sshd

ntrights +r SeAssignPrimaryTokenPrivilege -u cyg_server
ntrights +r SeCreateTokenPrivilege -u cyg_server
ntrights +r SeTcbPrivilege -u cyg_server
ntrights +r SeServiceLogonRight -u cyg_server
ntrights +r SeDenyRemoteInteractiveLogonRight -u cyg_server

net localgroup "administrators" sshd /add

and also
c:\cygwin\bin\bash.exe --login /bin/mkpasswd -l -d >/etc/passwd
c:\cygwin\bin\bash.exe --login /bin/mkgroup -l -d >/etc/group

but when I then run
c:\cygwin\bin\bash.exe --login /usr/bin/ssh-host-config --yes --cygwin ntsec --pwd loser as the administrator of the pc (not in domain) it seems to run fine thru most if the script but then when it gets to the line where it asks if you want to change the user of cyg_server it is AUTOMATICALLY answering yes which then I have to retype it in.  I am running version 2.573.2.3

what is the problem.  Can someone please help?


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]