This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [1.7] rebaseall doesn't solve the problem

On Mar  4 09:49, Corinna Vinschen wrote:
> On Mar  4 01:01, Charles Wilson wrote:
> > Charles Wilson wrote:
> > > Corinna Vinschen wrote:
> > > 
> > >> Can you tweak the tool so I can test that next week?
> > > 
> > > Attached,
> > 
> > It helps when you actually attach the file.
> Heh :)  Thank you!  I'll give it a whirl on my TS system.


- I removed all Cygwin traces from my TS test machine.
- I disabled DEP for all applications and rebooted (necessary so that the
  next step succeeds).
- I installed a 1.7 distro from scratch.
- I re-enabled DEP for all apps and rebooted.
- I disabled the TS hack in the Cygwin DLL, rebuilt it and installed it
  on the TS machine.
- I started bash and it crashed.
- I started ash (always works for some reason).
- I called "./peflags -t 1 /bin/bash"
- I started bash and... it worked!
- I started GDB and it crashed.
- I called "./peflags -t 1 /bin/gdb"
- I started GDB and it worked.
- I started grep and...
- I called ... /bin/grep
- ... worked.
- ... and ssh ...
- ... and mkpasswd ...
- ... and mkgroup ...

So it seems that setting the TS-aware flag for all applications by
default is the way to go, same as in Visual C++.

Unfortunately that doesn't help us with existing packages in the distro,
only for new ones, but at least we now have the peflags tool for these

Nevertheless, I will disable the TS hack in Cygwin 1.7 now.  We have a
much better solution now and the hack was a real PITA performance-wise.

Thank you very much for doing that!  I think this deserves a gold star.
Igor?  Are you still with us?  I didn't see a mail from you since October.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]