This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Please test the latest snapshot!

On Aug  6 13:04, Christopher Faylor wrote:
> On Thu, Aug 06, 2009 at 12:45:31PM -0400, Christopher Faylor wrote:
> >On Thu, Aug 06, 2009 at 06:37:34PM +0200, Corinna Vinschen wrote:
> >>On Aug  4 18:36, Christopher Faylor wrote:
> >>> On Tue, Aug 04, 2009 at 02:00:42PM -0400, Christopher Faylor wrote:
> >>> >On Tue, Aug 04, 2009 at 04:30:49PM +0000, Eric Blake wrote:
> >>> >>> I'm still seeing some weird stuff in the latest snapshot.  This is
> >>> >>> a fresh install, with nothing other than the Base category + git,
> >>> >>> and substituting just cygwin1.dll.
> >>> >>> 
> >>> >>> $ git clone git://
> >>> >>> Initialized empty Git repository in /home/eblake/libsigsegv/.git/
> >>> >>> fatal: write error (Socket operation on non-socket)
> >>> >>
> >>> >>I'm seeing this behavior even as far back as snapshot 20090706, so it
> >>> >>may be some BLODA on this particular machine, rather than a new
> >>> >>failure in the latest snapshot.  Other than this weird behavior of
> >>> >>git, I haven't seen anything else misbehave with the 20090804 snapshot.
> >>> >
> >>> >Does that mean you don't see the problem with the 20090704 snapshot or
> >>> >that you haven't tested that far back?
> >>> >
> >>> >I'll try this command out as soon as I can.
> >>> 
> >>> I tried it and it failed as you indicated.
> >>> 
> >>> The next snapshot should fix the problem.
> >>
> >>FWIW, if I change the send/recv buffer sizes back to 65536 in fdsock,
> >>it still works for me, every time I try it.  I tried on XP SP3,
> >>Server 2008, and Windows 7.
> >>
> >>Is it possible that this is actually a BLODA problem?
> >
> >I was, until yesterday, using the McAffee virus checker.  I'll try it again
> >with that turned off.

IIRC from reports on this list, it might not be sufficient to disable
it, rather you would have to deinstall it.  There's probably some
serious Windows DLL hooking going on.

> If I set the buffer size up to 65536 it still fails.  If I set it down
> it still succeeds.  FWIW, my previous tests were with Windows XP SP2.
> Given that Eric is still reporting problems, I guess it could still be
> BLODA though.

Is there a chance this is a XP problem which has been fixed with XP SP3?
Additionally to XP SP3, 2008, and Windows 7, I now tried with Windows
2000 and it still works for me.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]