This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Problem with Apache2 and mod_dav_svn / mod_authz_svn again

So, to follow-up on this issue, I have eliminated all known BLODAs and am still seeing the same basic error, though now, with Symantec Endpoint Protection TOTALLY removed from my system, I see the following error when I try to start /usr/sbin/httpd2 with the 2 svn modules loaded:

5 [main] httpd2 5192 E:\cygwin\usr\sbin\httpd2.exe: *** fatal error - unable to remap E:\cygwin\lib\apache2\ to same address as parent(0xDE0000) != 0x12F0000
6 [main] httpd2 4628 fork: child 5192 - died waiting for dll loading, errno 11

With SEP, I don't get that error, I just get the failed to fork error, so this is a clue, no doubt. But here, even without the SEP, rebooted clean of any virus checker and certainly clean of any known BLODA, I'm still seeing this problem. So, it is likely we have another BLODA on our hands.

I also tried to disable Spybot Search and Destroy resident, but that did not help.

I've uploaded my cygcheck to pastebin:

But note, I disabled the "sshd", "Python Web Server" and "Subversion Service" when I ran the test and I still got that error.

Finally, here is a PS of my system as running today:

I've highlighted a few places. The Symantec Endpoint Protection I highlighted because that was not running during my test -- it was uninstalled. Also, I highlighted the Spybot Application and the Ad-Aware application as although I tested with Spybot Disabled, these 2 may be our best candidate for BLODAing.

Anyone have any other thoughts on what could be the issue?

Thanks in advance,


-- Problem reports: FAQ: Documentation: Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]