This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem with GCC4[1.7]

Angelo Graziosi wrote:
> Dave Korn wrote:
>> For now I recommend uninstalling gcc4-ada, or just 'rm' the gnat
>> executables
>> from /bin.  I'll have a somewhat better (at least to the extent of not
>> hanging
>> like this) version out in 4.3.4-1 very shortly.  Apologies for the
>> inconvenience.
> Don't worry! :-) I understand your great and hard work!
> For completeness, running (without arguments):
> $ /usr/lib/gcc/i686-pc-cygwin/4.3.2/gnat1.exe
> prints the help and hangs in the same manner...
> ...and, just a curiosity, did it worked in 1.7 before?

  I don't see how it ever could have done, but then I ran the GNAT and ACATS
testsuites before I shipped 4.3.2-2 and it seemed to work there.  I think the
autoconf test for ada at the toplevel is new, which would explain why we never
saw this before.  (I also think the problem might be caused by a lack of
#ifdef IN_RTS around the call to __main that I added in __gnat_initialize,
because just ripping it out altogether causes lots of FAILS.  As a result,
4.3.4-1 is going to need at least one more spin before I can release it, alas.)


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]