This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Changing HOME for PERL

OK as you and Larry kindly suggest I will go back to basics and re-look
at the problem report.  Please know that I did read the Cygwin site
carefully before submitting so as to not upset and to also respect the
folks out here.

Before I go and end this thread can you tell me if the Perl.exe I have
in Cygwin looks correct?

I can cd /usr/bin 
and the Perl there is:

dextem@USENDEXTEML1C /usr/bin
$ ls -la Perl.exe
-rwxrwxrw-+ 1 dextem mkgroup-l-d 34304 Jul 19  2007 Perl.exe

I am not seeing the 'x' for execute however and maybe this is the issue?

Thank you,

-----Original Message-----
From: [] On Behalf
Of Jeremy Bopp
Sent: Thursday, August 27, 2009 10:27 AM
Subject: Re: Changing HOME for PERL wrote:
> Also the command od -c, shows \n ONLY throughout the
> excepts a couple sots near the end of the file.  Do I need to worry
> about those couple spots \n\n doubles appears.

No, you don't need to worry about \n\n sequences.  They just indicate
that you have empty lines in the file.  Try removing one of the empty
lines and see out the od -c output changes.

> ==================================================
> $ od -c
> 0000000   #   !   /   u   s   r   /   b   i   n   /   p   e   r   l
> 0000020  \n   $   x       =       3   ;  \n   $   c       =       "
> 0000040   e       "   ;  \n   $   s       =       $   c       x
> 0000060   x   ;  \n   $   b       =       "   b   y   e   "   ;  \n
> 0000100   r   i   n   t       "   $   s   \   n   "   ;
> 0000120                       #   h   e       h   e       h   e  \n
> 0000140   r   i   n   t       $   s       .       "   \   n   "   ;
> 0000160                       #   h   e       h   e       h   e  \n
> 0000200   $   a       =       $   s       .       $   b   ;  \n   p
> 0000220   i   n   t       $   a   ;
> 0000240                   #   h   e       h   e       h   e       b
> 0000260   e  \n  \n
> 0000263
> ==================================================
> Now when I run the file I am getting same error without the ^M
> $ ./
> bash: ./ /usr/bin/perl: bad interpreter: Permission

I went ahead and recreated your script based on your od -c output, but
as expected, I can't recreate your problem without purposely breaking my
Cygwin installation.  Only by removing all execute permissions from my
Perl program at /usr/bin/perl am I able to get the error you receive.

Now I just took a closer look at what you did earlier to work around
this problem when you changed the SheBang line to:


What you have done by making this change is direct Cygwin to run what is
most likely a Windows-native Perl installation installed into C:\PERL in
order to interpret your script.  Since this change works for you, this
Perl installation is obviously good; however, this is *not* the Perl
installation under Cygwin.

Since your Cygwin-based Perl installation seems to be lacking some
necessary permissions, it appears that there is something wrong with
your Cygwin installation.  Following the problem reporting guidelines
( will provide more information which
will hopefully help the Cygwin maintainers identify the cause of the

Good luck.


Problem reports:
Unsubscribe info:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]