This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: HEADSUP: Check mirror carefully when updating your 1.7 installation

On Wed, Dec 23, 2009 at 03:17:31PM +0000, Andy Koppe wrote:
>2009/12/23 Christopher Faylor:
>> On Wed, Dec 23, 2009 at 12:37:31PM +0100, Corinna Vinschen wrote:
>>>I just found an unfortunate side-effect of the move of the Cygwin 1.7
>>>release area. ??If you use the new setup.exe for Cygwin 1.7 on a mirror
>>>which hasn't catched up with the update yet, you are in danger to
>>>overwrite your 1.7 installation with a Cygwin 1.5.25-based installation.
>> Shouldn't you get a warning when you use a mirror that is no longer listed?
>> According to the source, you should see this message:
>> ??One or more mirrors you have selected is/are not on the
>> ??list of official Cygwin mirrors any more.
>> ??It/They may be out of date or missing some packages.
>> ??This affects the following mirror(s):
>I did get that message on one machine, which I think was set to the
>tu-dresden mirror, but not on another a few hours later that was set
>to The latter looked like it was going to
>downgrade to 1.5 in the 'partial' package view. I didn't press Next to
>try. is actually listed as being up-to-date so if that really
was happening then it looks like something else is going on.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]