This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 1.7.1: Mintty/bash window start: -bash: regtool: command not found

Andy Koppe wrote:
2009/12/23 Lee D. Rothstein:
Just installed 1.7.1. Bravo, again.

Everything seems to be working okay, but every time I start up a Mintty/Bash
window I get the following
error message.

-bash: regtool: command not found

Shortcut is:

C:\_0\bin\mintty.exe --icon=c:\_0\cygicons-hippo-vista-0.dll,10 -

'regtool' does not appear in my profile nor my bashrc.


There's a regtool call in /etc/profile:

PRINTER="`regtool -q get '\user\Software\Microsoft\Windows
NT\CurrentVersion\Window\Device' | sed 's/,.*$//'`"

I can reproduce this as follows:

- Leave a Cygwin session open.
- Run setup.exe
- Select reinstall for cygwin-1.7.1-1.
- Click next
- "in-use files detected" appears
- Click retry.

Strangely, 'retry' is accepted even without closing all Cygwin
processes. But it doesn't seem to make a difference to the outcome
anyway: regtool and also mount and ps aren't installed.

It can be fixed by reinstalling the cygwin package again, this time
without any Cygwin processes running.

Thanks, Andy, this fixed the sucker! And too, regtool did get installed.

Is this a setup bug?

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]