This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 1.7.1: Mintty/bash window start: -bash: regtool: command not found

* Lee D. Rothstein (Wed, 23 Dec 2009 13:43:02 -0500)
> Andy Koppe wrote:
> > 2009/12/23 Lee D. Rothstein:
> > I can reproduce this as follows:
> >
> > - Leave a Cygwin session open.
> > - Run setup.exe
> > - Select reinstall for cygwin-1.7.1-1.
> > - Click next
> > - "in-use files detected" appears
> > - Click retry.
> >
> > Strangely, 'retry' is accepted even without closing all Cygwin
> > processes. But it doesn't seem to make a difference to the outcome
> > anyway: regtool and also mount and ps aren't installed.
> >
> > It can be fixed by reinstalling the cygwin package again, this time
> > without any Cygwin processes running.
> >
> >   
> Thanks, Andy, this fixed the sucker! And too, regtool did get installed.
> Is this a setup bug?

Yes. The problem is even worse: it does not retry to update the "in-
use" files again even after the file is not in-use (including reboot).

Scenario: tried to update 1.7.0 installation. Shut down sshd and cron, 
forgot ssh-agent. Got "in-use" message saying either shut down the 
process or you have to reboot. Killed ssh-agent, tried again, setup went 
ahead. Cygwin was still on 1.7.0. Rebooted: no change. Reverted VM to 
snapshot, closed /all/ Cygwin process: no problem.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]