This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Defeated by "alternatives": unison

Since updating my Cygwin installation to version 1.7, I can no longer
run "unison" from the command line. Unison uses the "alternatives"
facility to select among multiple installed versions. The symbolic links
all look to be set up properly, but the program can't be invoked in the
normal ways.

I've tried this same sequence of commands using the shells zsh, bash,
and ash, and all fail in the same way.


| % which unison
| unison not found
| % /usr/sbin/alternatives --display unison
| unison - status is manual.
|  link currently points to /usr/bin/unison-2.27
| /usr/bin/unison-2.32 - priority 2032
| /usr/bin/unison-2.27 - priority 2027
| Current `best' version is /usr/bin/unison-2.32.
| % ls -l /usr/bin/unison*
| -rwxr-xr-x 1 seh root 1076224 2009-10-01 11:27 /usr/bin/unison-2.27.exe
| -rwxr-xr-x 1 seh root 1123840 2009-10-01 11:31 /usr/bin/unison-2.32.exe
| lrwxrwxrwx 1 seh None      28 2005-03-24 22:09 /usr/bin/unison.exe ->
|                                                /etc/alternatives/unison.exe
| torus:~% /usr/bin/unison
| zsh: no such file or directory: /usr/bin/unison
| % /usr/bin/unison.exe
| zsh: no such file or directory: /usr/bin/unison.exe
| % /etc/alternatives/unison
| Usage: unison [options]
|     or unison root1 root2 [options]
|     or unison profilename [options]
| For a list of options, type "unison -help".
| For a tutorial on basic usage, type "unison -doc tutorial".
| For other documentation, type "unison -doc topics".

I used to just be able to type "unison" at the command prompt and invoke
it like any other program. Is this a permissions problem? I have found
that other programs using the "alternatives" facility work as
expected. Why is "unison" different?

[I've tried posting this message with the cygcheck output attached, but
 the messages get rejected.]

Steven E. Harris

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]