This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

AW: [bulk] - Re: One Problem solved other found -> dlclose not calling destructors


Dipl. Phys.
Norbert Zacharias
Wind Measurements & Power Curve Measurements
Ebertstrasse 96
26382 Wilhelmshaven

Tel.:   +49 4421 4808 876

Fax:    +49 4421 4808 843

Home:   http://

DEWI GmbH - Deutsches Windenergie-Institut, Wilhelmshaven
Commercial Register No.: Amtsgericht Oldenburg, HRB 130241
Managing Director: Jens Peter Molly
Chairman of the supervisory board: Ministerialrat Dr. Niels Kämpny

P Please consider the environment before printing this email.

-----Ursprüngliche Nachricht-----
> Von: Christopher Faylor []
> Gesendet: Donnerstag, 4. Februar 2010 16:30
> An:
> Betreff: [bulk] - Re: One Problem solved other found -> dlclose not calling
> destructors
> On Thu, Feb 04, 2010 at 03:10:04PM +0100, DEWI - N. Zacharias wrote:
> >after Corinna solved the executable flag issue on NWFS another strange
> >thing happened.
> >
> >I use Eclipse Version: 3.4.2 Build id: M20090211-1700 with the EPIC
> >Plugin to develop Perlscripts.
> >
> >After installing the new cygwin1.dll which handles the NWFS execute
> >flag my debugger hangs at the stage 'launching delegate' .
> >
> >Then Corrinna sends me a cygwin1.dll where the patch
> > was not applied.
> >
> >With this dll the debugger works.  So it seems that the patch has side
> >effects.
> Sorry but this really isn't very helpful.  "With this dll the debugger
> works" doesn't provide enough details.

For details please ask Corrinna, she provides the dll which works.

>  What destructors are not being called?

Sorry I don't  know!
I Only see the effect and Corinna tell me that she build the
Dll which works without the obove mentioned patch.

> Do you have a test case?
Get eclipse, install epic Perl Debug Plug-in  0.6.27 , write a simple perl script like

#! /usr/bin/perl -w
print("hello world\n");

try to debug as Perl Local and you will see the debugger hanging around.

Sorry but neither I have the knowledge to figure out which call of perl
triggers the problem nor I have the  time to get it.

Have a good time anyway
> cgf
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]