This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

starting /usr/bin/ssh using run.exe is broken?

I have been using this setting: "c:\cygwin\bin\run.exe /usr/bin/ssh"
in one of the native windows app (specifically TortoiseSVN) that
points to the path of ssh client. This has been working fine for the
last 1yr, but after I updated cygwin to 1.7.1 ssh started to just
hang. If I set the path directly to "c:\cygwin\bin\ssh.exe" then it
works fine, but obviously I would start seeing several unwanted
console popups that stay on as long as the operation is going on.
To narrow down to see if it is the newer version of run.exe
(1.1.12-11) that is breaking (rather than the newer version of
cygwin), I tried to install the older versions, but I can only select
the immediate previous version (1.1.12-10). I do have versions as far
as 1.1.10-1 but how do I force setup.exe to install this version? I
tried removing the rest temporarily from the local package directory,
but it would show the older versions. This reminds me of a
(or shell script, that took the .tar.gz2 file and
installed it but I can't find it on the net anymore.
How do I isolate the problem and see where things are breaking? I
would appreciate any help on this.

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]