This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Fetchmail call to procmail no longer works under Cygwin 1.7.1-1

Dear all,

I recently upgraded to cygwin 1.7.1-1 on two computers:

-- an ASUS netbook running Windows XP (German edition)
-- a Fujitsu-Siemens desktop running Windows XP (English)

The software on the C: partitions of the two computers
has been installed separately (including c:/cygwin and c:/cygwin/etc).
However, all data-file partitions -- which include the local configuration
files for fetchmail and procmail -- are identical.  Essentially, I
move the data back and forth in order to work either on one machine or
on the other.

I use fetchmail to pick up my mail using POP3 ("nokeep",
"fetchall").  Fetchmail passes each message to procmail for
distribution to my mailboxes with:

	mda "/usr/bin/procmail -d %T"

Mail pickup with fetchmail and distribution with procmail has
worked flawlessly for years and continues to work flawlessly
on the ASUS _netbook_.

The problem is that since the upgrade to Cygwin 1.7, the fetchmail
on my _desktop_ computer no longer passes the incoming messages to the
MDA procmail.  Each incoming message, retrieved with POP3, is saved
undelivered as an individual file in /var/spool/mail/tbaker, e.g.:

	/var/spool/mail/tbaker/msg.IdE ...

On the ASUS netbook, the procmail.log confirms delivery of the messages.
On the desktop machine, the procmail.log is not written
to at all, which I take to mean that procmail is not even being executed.

I have extensively compared the two installations:

-- /etc/fstab files are identical
-- the drive aliases and options listed by "mount" are identical (aside
   from an additional CD-ROM drive on the desktop)
-- the local configuration files for fetchmail and procmail are identical
   (i.e., they are copies of each other, with identical permissions and
-- specifically, the fetchmailrc command mda "/usr/bin/procmail -d %T"
   is identical
-- permissions and ownership of the /usr/bin/procmail and /usr/bin/fetchmail
   executables are identical
-- permissions on the mailboxes where the mail is supposed to be delivered
   are identical
-- versions of the relevant programs are identical:
	base-cygwin                    2.1-1
	cygwin                         1.7.1-1
	fetchmail                      6.3.9-1
	procmail                       3.22-10

These are single-user machines, so I have administrative privileges
on each machine.  On each machine, /etc/fstab.d is empty.

I spent the better part of my Sunday yesterday trying to imagine where
else the problem could possibly lie.  I have turned over all the stones
I could think of turning.  I ran setup.exe several times on each machine
to make sure everything was completely up to date.  The one place I haven't
compared carefully is the Win32 registry, but I thought its use for
mapping drives was being superseded by fstab, and I'm not sure what I'd
be looking for there anyway.

Mail continues to work great on the netbook and not on the desktop.

Is there anything else I can check or verify?  Any advice gratefully

Many thanks,

Tom Baker <>

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]