This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Fetchmail call to procmail no longer works under Cygwin 1.7.1-1

On Mon, Feb 22, 2010 at 5:02 PM, Jason Tishler <> wrote:
> On Mon, Feb 22, 2010 at 09:12:00AM -0500, Thomas Baker wrote:
>> The problem is that since the upgrade to Cygwin 1.7, the fetchmail
>> on my _desktop_ computer no longer passes the incoming messages to the
>> MDA procmail. ÂEach incoming message, retrieved with POP3, is saved
>> undelivered as an individual file in /var/spool/mail/tbaker, e.g.:
>> Â Â Â /var/spool/mail/tbaker/msg.AdZ
>> Â Â Â /var/spool/mail/tbaker/msg.IdE ...
> Is /var/spool/mail/tbaker a directory on your desktop? ÂI expected it to
> be a (mbox formatted) file.

Ah, how interesting!  It is indeed a directory.  I deleted the directory,
sent some test messages to myself, and now at least they are indeed accumulating
in one single mbox file called TBaker.  That is certainly progress!

> Does running fetchmail with multiple -v options and/or procmail in
> VERBOSE=yes mode help located the problem?

I ran the fetchmail diagnostic:

	env LC_ALL=C fetchmail -V

and got some relevant bits of information:

	Fallback MDA: /usr/bin/procmail -d %T
	Fetchmail will forward misaddressed multidrop messages to TBaker.
  	Messages will be delivered with "/usr/bin/procmail -d %T".

and from

	env LC_ALL=C fetchmail --nodetach -vvv --nosyslog

I get

        fetchmail: about to deliver with: /usr/bin/procmail -d 'TBaker'
        fetchmail: POP3> DELE 1

Procmail, on the other hand, is already set to VERBOSE and writes to
a logfile procmail.log.  On the netbook, where procmail works, it does write
to the logfile.  On the desktop, where procmail does not work, it does not
write to the logfile, making me think it is somehow not even being called.

When I compare the output of these commands between the netbook (where it
works) and the desktop (where it does not), the only difference I see is that
on the netbook, the log says

        fetchmail: about to deliver with: /usr/bin/procmail -d 'tbaker'

(i.e., "tbaker" all in lower case).  I have tested several variants in
.fetchmailrc, e.g.:
	mda "/usr/bin/procmail -d %T"
	mda "/usr/bin/procmail -d tbaker"
	mda "/usr/bin/procmail -d 'tbaker'"

and export USERNAME=tbaker, etc, but none of these has worked yet.

If my mail is now accumulating at least in one mbox file, is there perhaps
a way I could try running procmail on that file manually?


Tom Baker <>

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]