This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: unable to login using ssh and password

> Hi,
> I have installed cygwin on a windows 7 system because I need to remotely
> start graphical Applications using ssh.
> Setting up the sshd works fine using the ssh-host-config and
> ssh-user-config scripts. I can access the server with ssh using password
> and keyfiles, but I can't start a graphical program.
> So I changed the settings of the sshd service from using "cyg_server" to
> "local service account" and activated "Allow Service to interact with
> desktop". That the sshd starts again, I changed the owner of /var/empty
> from cyg_server to SYSTEM and the sshd starts again.
> Now I'am able to connect to the server from my linux system using a
> keyfile (ssh -i file user@server), but I can't access the system using
> password authentication.
> With "access" I mean, that I don't get a prompt. I get a login and I
> can enter my password. I also get the correct "Last login: ...." message
> from the server, but then the connection is terminated.
> I already searched a lot in the mailinglist and googled around. I found
> a few people having the same problem and they solved it by changing
> permissions of various files (for example the bash and the /etc/ssh*
> files). I also regenerated my passwd and group files running "mkgroup"
> (twice, once with -l and the other time with -d) and "mkpasswd -cl" with
> no effect...
> I also tried running "cyglsa-config" and a "rebaseall"...
> What confuses me is that I'm able to connect to the windows server from
> the windows host itself by running "ssh localhost".
> I think that this is not really a problem of a sshd misconfiguration but
> a problem of wrong permissions. But why am I able to connect from the
> host itself with a password, and why can I login from remote using
> keyfiles?
> Thank you
> Martin
> P.S. Im using the default sshd_config and attached the output of
> cygcheck as described on If you need more Information just
> let me know.

It looks like you're running 1.7.1 and there were some pretty
serious problems with initializing the user profile that are
now fixed.  You might want to try at least 1.7.2 (I think
you'll get 1.7.4 as the default right now).

Also if you want to diagnose this further, trying running
"Process Monitor" from and filter for
the potential failing processes (bash.exe maybe) and look
to see if it's failing on accessing non-existent registry

Eric Berge


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]