This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Cygwin 1.7.8 on Windows 7 Pro x64 Doesn't See Programs Added to C:\Windows\System32 Directory

On Sat, Apr 16, 2011 at 5:40 AM, Leon Vanderploeg  wrote:
> Greetings,
> I recently loaded Windows 7 Pro x64 on my laptop, and installed Cygwin
> 1.7.8. ?I run a (GCC Compiled) backup program that calls diskshadow.exe --
> which I added to the C:\Windows\System32 directory. ?The program faults
> because the shell call can't find the program.
> The Path variable is set with C:\Windows\System32 as the first entry, and
> there are no errors. ?I've started new command prompts each time I edited
> the Windows PATH variable, and even tried rebooting.
> Opening an elevated command prompt, windows finds the program just fine from
> the path variable. ?Running Bash, the which command doesn't find
> diskshadow.exe, even though it is there (in C:\Windows\System32).

less than 10 days ago

that refers to

> While still in the bash window (from an elevated command prompt), If I cd to
> /cygdrive/c/Windows/System32 and do "ls -la disk*", it finds other disk
> programs such as diskpart.exe, but not diskshadow.exe, even though I know it
> is there! ?This is also true of libcurl-3.dll that I added to
> C:\Windows\System32. ? ?Windows sees it fine, but not bash.
> I have been reading documentation and googling till I can't see straight.
> Can anyone please help me understand what is happening?
> Thanks in advance!
> Leon

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]