This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: sshd on win7 x64

On 8/12/2011 11:49 AM, Alexey Luchko wrote:

I've got back and tried to set up sshd again.

Now it tricks me in other way. It fails on seteuid() when I try to connect
with a domain user.
$ /usr/sbin/sshd.exe -dd


debug1: temporarily_use_uid: 11135/10513 (e=1003/513)
seteuid 11135: Permission denied


I've tried to login with a local user. It seems it seteuid() works with
local user. But then it claims again that chown() on tty fails:

Yeah, it's a known issue that 'sshd' cannot log you in as a domain user unless the user running the 'sshd' service is also a domain user with the correct permissions. You can check in the archives if you want details of how to set this up but generally it's easier to just stick with local users if that's acceptable. The 'ssh-host-config' script can and does set up the ability to handle local users.


debug1: session_pty_req: session 0 alloc /dev/tty3
chown(/dev/tty3, 1001, 513) failed: Bad file descriptor

This is weird. I've not seen it reported before by others and certainly haven't seen it myself. Perhaps this is a case of BLODA?




A: Yes.
> Q: Are you sure?
>> A: Because it reverses the logical flow of conversation.
>>> Q: Why is top posting annoying in email?

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]