This is the mail archive of the
mailing list for the Cygwin project.
Re: Where is /bin/nologin
Corinna Vinschen-2 wrote:
> On Oct 14 14:04, Andrey Repin wrote:
>> I would advice against giving any clues about account status, for
> It's what Linux' /sbin/nologin' prints, too. Actually it's the whole
> idea of /sbin/nologin' per the man page:
> $ man nologin
> NOLOGIN(8) BSD System Manager's Manual
> nologin â politely refuse a login
> Just `exit 0' should be replaced with `exit 1' since
> nologin displays a message that an account is not available and exits
> Corinna Vinschen Please, send mails regarding Cygwin to
> Cygwin Project Co-Leader cygwin AT cygwin DOT com
> Red Hat
> Problem reports: http://cygwin.com/problems.html
> FAQ: http://cygwin.com/faq/
> Documentation: http://cygwin.com/docs.html
> Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple
Nice script! Would be cool if it would be part of cygwin. Btw. was the
/etc/nologin.txt your addition? I think the original nologin doesn't even do
that. At least not on Debian, where I just checked.
Although in general I agree with Andrey. I forgot all about /bin/false. So I
am using that now. In fact I checked on my Linux box. I see that most
"no-shell" users have /bin/false in /etc/passwd (like ftp or mysql). But
others have nologin (e.g. user sshd on my machine).
View this message in context: http://old.nabble.com/Where-is--bin-nologin-tp32647652p32657023.html
Sent from the Cygwin list mailing list archive at Nabble.com.
Problem reports: http://cygwin.com/problems.html
Unsubscribe info: http://cygwin.com/ml/#unsubscribe-simple