This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Can't get sshd to work

Jeremy Bopp-3 wrote:
> On 11/4/2011 08:58, gabier wrote:
>> Ken Brown-6 wrote:
>>> On 11/4/2011 8:17 AM, gabier wrote:
>>>> Hi everybody,
>>>> First post here, I am a Cygwin newbie. I try to implement ssh
>>>> connectivity
>>>> between my Windows 7 desktop and a FreeBSD/FreeNAS server.
>>>> Openssh shell commands seem to work, but sshd is not running and thus
>>>> network commands issued from the server abort because of connection
>>>> refused.
>>>> The sshd windows service is automatically started at windows startup,
>>>> but
>>>> it
>>>> is not running. If I start the service by Windows command, it starts
>>>> and
>>>> stops immediately (Windows saying).
>>>> If I start it at the command line with ssh I tried 2 ways
>>>> $ /usr/sbin/sshd.exe
>>>> /etc/sshd_config: No such file or directory
>>>> $cygrunsrv  --start sshd
>>>> cygrunsrv: Error starting a service: OpenService:  Win32 error 5:
>>>> AccÃs refusÃ.
>>>> I searched this forum but I am lost in the variety of parameters and
>>>> reasons
>>>> of not working, as well as different versions.
>>>> In fact I downloaded the cygwin setup, and installed the default
>>>> packages,
>>>> and afterwards I installed the openssh package (5.9).
>>>> What is to be done in order to debug this problem ? Is sshd simply
>>>> lacking a
>>>> sshd_config file ? Then how to build it ?
>>> Did you run /usr/bin/ssh-host-config ?
>> No, I had not. I did not know I had to. 
>> Well, I ran it, but it asks me if I want privileged separation or not. I
>> searched a little on internet to know what this is. It seems a good
>> architecture, but I am feared that being rather new it introduces new
>> problems. Does it work well now  and is there a manual or how to in this
>> context ? If I choose NO, is it dangerous but more simple ?
> Privilege separation has been around for years now, so there's no risk
> with using it, really.  Unless you know better, you should take all the
> defaults provided by ssh-host-config.  You can always run it again later
> to change something.
> -Jeremy
> --
> Problem reports:
> FAQ:         
> Documentation:
> Unsubscribe info:
Thanks Ken and Jeremy
I took the default, it went on without error, and at last I could start my
sshd service on windows 7 without immediate abortion.
As a first test I issued a scp command from the freebsd server as follows
(first, login and second scp command asking to transfer "testfile.txt" from
the windows computer at to the freenas server.

$ssh gabriel@freennas
Password etc... Welcome... OK
$scp gabriel@ 

Now the connection is established but there is a password problem

Permission denied, please try again.
Permission denied, please try again.
Permission denied (publickey,password,keyboard-interactive).

The 2 users who communicate have the same name gabriel and the same
password, but this password is denied. Is this a known problem  and how can
I debug it.
View this message in context:
Sent from the Cygwin list mailing list archive at

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]