This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

gdb broken inside emacs (again? still?)

Hi all,

Attempting to run gdb inside emacs with an executable file name argument (with or without --annotate=3) causes it to seg fault (no surprise, known issue). Running just `gdb' from emacs allows it to initialize, but attempts to load a file or indeed perform any command hang until a double-^C cancels the attempt (reporting "C-c C-cquit"). Ironically, even `quit' hangs, so you have to use ^D to exit. Debugging anything within emacs is thus completely impossible at this time. I've tried with a home-compiled gdb (same version) with no better luck. I'm building an emacs-23 from scratch, but I'm pretty sure I've already tried that before, without any conclusive improvement.

I know this has come up before, and that it has been "resolved" before for me and for others, but it keeps recurring (usually whenever I actually need to debug something) and I can't find any reliable way to make the problem go away.

Do the latest snapshots contain changes which should fix the problem?

I'm on an win7-64 system, running the 13 Oct dll snapshot, after a rebaseall. Relevant package versions are below (setup.exe doesn't advertize any newer ones):
binutils                    2.22.51-1
gcc4                        4.5.3-3
gcc4-core                   4.5.3-3
gcc4-g++                    4.5.3-3
gcc4-java                   4.5.3-3
gdb                         7.3.50-2
emacs                       23.3-3
emacs-X11                   23.3-3

Thanks, Ryan

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]