This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: "Couldn't allocate heap" - tried rebasing

On 11/22/2011 9:21 PM, Jesse Ziser wrote:
On 11/15/2011 11:33 AM, Jesse Ziser wrote:

Tried the new version of rebase. Did not fix the problem. Tried rebase -s -i. No asterisks, so presumably no collisions. Tried uninstalling Sophos. Did not fix the problem. Tried the 2011-11-08 snapshot. Seems to fix the problem!

I'm not comfortable deploying a snapshot throughout the building,
though. I will roll back to 1.5 for now and wait for that snapshot to
make it to a release. Thanks!

Actually, I just noticed this remark:

"In summary, current Windows implementations make it
impossible to implement a perfectly reliable fork, and occasional
fork failures are inevitable."

in winsup/doc/overview2.sgml in the source tree. Does that mean that,
even with the improvements mentioned above, we cannot expect important
Cygwin apps/scripts to always work reliably in a post-WinXP world? My
company has been moving from Win2K/XP to Win7, so this would be
important info for us.

So how serious is the above remark? I don't see anything quite that
strongly-phrased in the FAQ. Maybe it should be mentioned there?

As user of W7/64 and latest shapshots, I only noticed that a rebasall is needed more frequently than on XP. After rebaseall things are usually smooth.


-- Problem reports: FAQ: Documentation: Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]