This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

With the latest snapshot, cygrunsrv segfaults but works after it's recompiled

With the latest cygwin1.dll snapshot, the existing cygrunsrv binary
(version 1.34-1, the latest version from setup.exe) segfaults on
startup, sending a message to the Windows Application log or syslog,
depending on whether syslog is running. This segfault happens only when
I try to run the service as my domain user; running my service as
cyg_server works fine. The crash happens with all service binaries, even
/bin/true and whoami.exe. The crash persists after I run rebaseall and

I can't get a stack trace because I can't attach a debugger to cygrunsrv
before it crashes, and the program doesn't leave any stack dumps behind,
or at least I couldn't find any. I tried using gflags to get windbg to
attach to cygrunsrv.exe on startup, but using this option seemed to have
no effect.

The program does sometimes spit out interesting log messages: "poorman:
PID 6016: starting service `' failed: redirect_fd: open (1, /dev/null):
17, File exists" This message was generated when I registered the
service with -1 /dev/null. The program outputs a similar message for any
log file supplied at registration time.

(Sometimes the program crashes with signal 11; other times, it prints
out an odd message about failing to open a log file, then exits with
status 1. I haven't recognized any pattern.)

If I build cygrunsrv myself from the source package (again for 1.34-1),
however, and replace /bin/cygrunsrv.exe with the one I built, the
service starts and runs fine. Did the ABI change?

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]