This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: "Bad address" error with redirection (stdout and stderr) in background process

On Wed, Jan 11, 2012 at 10:20:21AM -0500, Christopher Faylor wrote:
>On Wed, Jan 11, 2012 at 03:05:26PM +0000, Heiko Elger wrote:
>>I'm using latest snapshot and updated cygwin installation.
>>$ uname -a
>>CYGWIN_NT-6.1-WOW64 PCFX166 1.7.10s(0.259/5/3) 20120111 01:45:50 i686 Cygwin
>>I've done rebaseall and peflagsall.
>>I've found the following problem using make in parallel (-j) with multiple 
>>commands joined with semicolon (;) using cygwin and non-cygwin(cross compiler) 
>># just an example 
>>test.o: test.c
>>    echo compile ; cross-gcc -c test.c -o test.o
>>Having multiple targets like this and using for example 
>>$ make -j8 |& tee make.log
>>you will get a "bad address" error.
>>/bin/sh: cross-gcc.exe: Bad address
>>makefile:10: recipe for target `test.o' failed
>>I stripped down the problem to the following testcase:
>>$ cat ./
>>(( echo 123 ; cmd /c echo 456 ) |& tee tee.log ) &
>>executing the testcase will produce thr following output:
>>$ ./
>>$ 123
>>./ line 2: /cygdrive/c/Windows/system32/cmd: Bad address
>>If only redirecting stdout to tee all works fine.
>>The problem occurs ony while mixing cygwin and non cygwin programs.
>>Using snapshot 20110829 all works fine.
>>Any ideas?
>Do I infer from the above that you rigorously tried all snapshots
>through August and that was the first that worked or (more likely) you
>haven't tried a snapshot since August and now noticed a problem?

No need to answer that.  The upcoming snapshot should fix the problem.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]