This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Putty and pre-shared keys with Cygwin's sshd

Greetings, Andrew DeFaria!

>> Ok, now we're talking. There's indeed a tricky part involved, let me
>> try to cover it for you. On puttygen part, it seems you did it right. 
>> (Though, saving public key part is only required for ssh servers 
>> compliant with RFC4716.) On connection part... seems like you've 
>> supplied the right login name... On server part... First. Make sure 
>> your ssh server is configured to allow DSA keys. RSA keys are more 
>> common, as I've discovered. 
> Let's remain focused. As the subject states, the "server" is Cygwin, 
> running on my laptop. All I use is DSA myself. I can ssh to other 
> Unix/Linux systems. They can ssh to me using preshared key. I can ssh to 
> local host too. *I* use ssh, Cygwin's ssh and preshared keys. *Others* 
> often don't use Cygwin and/or don't have OpenSSH installed and say "I 
> have putty". I'm trying to help them. If it were me I'd just install 
> Cygwin and OpenSSH and be done with it.

Well, *I* am using Cygwin SSH and PuTTY. And I've had no issues other than
what I have explained.
One way or another, back or forth, to my Linux box, or from it, from my
Windows box to any imaginable server around the globe - no problem.
Using puttygen to create new keys, or converting keys from OpenSSH to
PuTTY, or the other way around to use for Cygwin's ssh in test box.
It just works. Exactly as described in PuTTY help file, chapter 8.2.

>> And sometimes servers configured to disallow DSA key authentication, 
>> even if they are offering DSA key themselves. Second, double-check 
>> server log for reason to refuse the key. The top (IMO) reason to 
>> refuse key authentication is wrong access mask on 
>> ~/.ssh/authorized_keys file. It must not be group- or world-writable.
> Well I checked my /var/log/sshd.log on my Cygwin laptop and it was of 0 
> length. Even tried to reproduce the problem, got the same error but 
> /var/log/sshd.log remains empty.

Check Windows event log. Though, it's obvious.
Also keep an eye on nearby discussion regarding SSHD issues. It may be your
case too.

Andrey Repin ( 22.01.2012, <07:15>

Sorry for my terrible english...

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]