This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: OpenSSH ssh-agent regression in 5.9p1-1: "Could not open a connection to your authentication agent" error

On Jan 28 23:01, Markus SchÃnhaber wrote:
> 28.01.2012 22:00, Philip Lowman:
> > There appears to be a regression in the most recent OpenSSH cygwin
> > package (5.9p1-1, built 1/18/2012) related to the ssh-agent program.
> I see that too.
> > The ssh-add program is unable to add SSH keys because the ssh-agent
> > program doesn't appear to be creating its socket file properly in
> > /tmp.
> AFAIKT the socket file is created - but the ssh-agent process dies
> shortly after being started.
> > 1. Install OpenSSH 5.9p1-1 in Cygwin (or upgrade to it)
> > 2. Run the ssh-agent program spawning a bash shell
> >   $ ssh-agent bash
> This seems to happen only if ssh-agent is told to spawn another process.

This is supposed to be fixed in Cygwin 1.7.10.  I just tried it and it
worked for me.  Please fetch a recent snapshot DLL from and try again.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Project Co-Leader          cygwin AT cygwin DOT com
Red Hat

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]