This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: "git clone" over ssh fails intermittently w/snapshot 20120123

Christopher Faylor wrote:

>> On Fri, Jan 27, 2012 at 02:32:54PM -0800, Kevin Layer wrote:
>> >I don't know what happened to the email in transit, but much
>> >information at the head of the email was chopped off.  From my outbox,
>> >here's the missing bit:
>> >
>> >*****************
>> >
>> >This is the failure mode:
>> >
>> >$ rm -fr test; git clone git:/repo/git/composer test
>> >Cloning into test...
>> >fatal: The remote end hung up unexpectedly
>> >fatal: early EOF
>> >fatal: index-pack failed
>> >
>> >$ 
>> >
>> >That is not using the git protocol.  The machine is called `git'.
>> >
>> >It fails most of the time, but it definitely works sometimes, and even
>> >has stretches of successes.
>> >
>> >At first, I thought it was isolated to large repos, but it definitely
>> >happened on some smaller ones.
>> You really haven't provided any details beyond "git clone doesn't work"
>> along with cygcheck output.

Well, I've shown the error message, and now answer the following
questions.  Hopefully that's enough.

>> You've previously reported that git worked great.  What changed?

This is a different machine.

>> What is the server that you're cloning from?  Another windows machine
>> running Cygwin?  A linux box?  Solaris?

The server is a linux box.

>> What does "large repo" mean to you?  I just tried this on the gcc repo
>> which is, from my point of view, pretty big.  The clone succeeded without
>> problem.

As I said, it does *not* have to do with size.

>> Where is the server located?  Is it on a local network or is it from
>> somewhere on the internet?

Local area network.

>> From my reading of the git documentation, using the host:/path syntax
>> means you're using ssh to connect to the other machine.  Have you
>> checked the logs of the server to see if anything is reported?

Have now and nothing.

>> Is this new behavior just seen with this snapshot or is it something you
>> noticed in 1.7.9?  If you've just seen it in the latest snapshot it
>> would be useful (as I've previously pleaded) to know in which snapshot
>> the bad behavior first showed up.

Never seen until the snapshot was installed.

More info:

Before the failure, I had removed and reinstalled cygwin, then
installed the snapshot.  The machine on which git works was upgraded
little at a time.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]