This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: mkpasswd and domain fail with windows network

On 3/14/2012 5:57 PM, Furash, Gary F - (furashg) wrote:
I've had this problem in the past with in other organizations and have never been able to get around it.

Problem: running mkpasswd w/ '-D' doesn't work/finish

Details: I am running Cygwin on Windows 7 64 bit in a typical work environment. I don't think that matters because I've had this exact problem before with other employers. The MKGROUP command with the domain parameter works fine, and populates all the real domains into /etc/groups. However,
- if I run mkpasswd with only -L, I just get the local accounts, none of
which are me (I'm part of a domain);
- if I run mkpasswd with -D, it just hangs indefinitely
- it doesn't matter if I run it as Administrator or not
- it doesn't matter if port 135 is open or not. I checked that
  because if I run the mkpasswd -D command with the laptop disconnected
  from the network, it actually fails with an RPC unable to contact domain error.
- using -D versus -d doesn't make a difference, as does adding -l
  (it just spits out the local accounts then fails or hangs.

This can take a long time in large domains. An alternative is to use the -c/-C to include just the current user.



A: Yes.
> Q: Are you sure?
>> A: Because it reverses the logical flow of conversation.
>>> Q: Why is top posting annoying in email?

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]