This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Can RPM packages be installed into Cygwin?

On 2012-4-19 1:08, Christopher Faylor wrote:
On Thu, Apr 19, 2012 at 12:05:38AM +0800, De-Jian Zhao wrote:
On 2012-4-18 22:03, Christopher Faylor wrote:
On Wed, Apr 18, 2012 at 09:13:20PM +0800, De-Jian Zhao wrote:
On 2012-4-17 13:58, Linda Walsh wrote:
Thank you, Linda.  When I saw the error message after installing some
packages to satisfy the dependencies, I was wondering why the rpm
package still complained about the already installed packages.  I was
not aware that cygwin and rpm were not sharing the 'database'.  Thank
you for making it clear to me.I will try the src.rpm when I am free.
So with all of the back and forth about this, you never realized that
Cygwin's setup.exe doesn't use RPM?  Wow.  Wasn't the fact that there
are no .rpm files in the distribution a big enough clue?
I never expect setup.exe will use rpm packages. There is a rpm command
in Cygwin. I just thought it could be used to install a rpm package.
And, although it is a very old, basically-unmaintained package, it can
be used to install rpm packages.

The rpm package complained about dependencies during installation. I did
think that the dependency could be solved by installing proper packages
through setup.exe.
But after installing some libraries through setup.exe, the rpm package
still complained the same as before.  It seemed that the rpm package
did not see the installed libraries at all.
I don't know if you are getting this or not but, yes, you can install
cygwin packages which would allow you to satisfy the needs for building
an rpm package.  That doesn't mean that rpm would magically know about
it since rpm maintains its own package database which obviously is not
updated by setup.exe.  So, while the programs you need to build an
rpm package may be available, rpm does not know this.  The fact that
we use setup.exe and "cygcheck" to query our packages should be a
huge clue that setup.exe does not know anything about rpm.

The --nodeps option to rpm will silence the dependency warnings but
it won't fix real problems if required packages are missing.

rpm is basically a curiosity on Cygwin.  It really isn't that useful.
If you want to build Cygwin packages, you should be investigating

Thank you, Christopher. Is there a way to export the package info or lib info of setup.exe to rpm? If they can share information, the problem will be easily solved.

Besides, I tried --nodeps option with src.rpm. It requires root privilege (see below). However, "sudo rpm" and "su root" both failed to work. Any way to fix it? Does Cygwin has a root user?
Administrator@acer /cygdrive/d/Blast/source
$ rpm --nodeps --install ncbi-blast-2.2.26+-3.src.rpm
warning: user coremake does not exist - using root
warning: group cppcore does not exist - using root
warning: user coremake does not exist - using root
warning: group cppcore does not exist - using root

As to cygport, it seems that a *.cygport file is required. How to get the file?
$ cygport ncbi-blast-2.2.26+-3.src.rpm install
*** ERROR: ncbi-blast-2.2.26+-3.src.rpm.cygport not found.
Administrator@acer /cygdrive/d/Blast/source
$ cygport cbi-blast-2.2.26+-src.tar.gz install
*** ERROR: cbi-blast-2.2.26+-src.tar.gz.cygport not found.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]